aboutsummaryrefslogtreecommitdiffstats
path: root/include/package-ipkg.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-11-07 16:15:22 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-11-07 16:15:22 +0000
commitee76e2804af260b48d29680f1d4ddc764d0a4b90 (patch)
tree5dc50ce1d84c29d9e22332dd6d6c17519dc056b8 /include/package-ipkg.mk
parent704a78d6b6d005caf38818730b6692846ff9dcfe (diff)
downloadmaster-187ad058-ee76e2804af260b48d29680f1d4ddc764d0a4b90.tar.gz
master-187ad058-ee76e2804af260b48d29680f1d4ddc764d0a4b90.tar.bz2
master-187ad058-ee76e2804af260b48d29680f1d4ddc764d0a4b90.zip
buildroot: isolate the .install stamp files for build variants (#12279)
This fixes missing embedded packages if multiple build variants are selected in the build config, e.g. missing ppp if CONFIG_PACKAGE_ppp=y and CONFIG_PACKAGE_ppp-multilink=m . git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34106 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/package-ipkg.mk')
-rw-r--r--include/package-ipkg.mk16
1 files changed, 8 insertions, 8 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 4ee0a96ad1..5de51ebb58 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -75,22 +75,22 @@ ifeq ($(DUMP),)
IDIR_$(1):=$(PKG_BUILD_DIR)/ipkg-$(PKGARCH)/$(1)
KEEP_$(1):=$(strip $(call Package/$(1)/conffiles))
- ifeq ($(if $(VARIANT),$(BUILD_VARIANT)),$(VARIANT))
+ ifeq ($(BUILD_VARIANT),$$(if $$(VARIANT),$$(VARIANT),$(BUILD_VARIANT)))
ifdef Package/$(1)/install
ifneq ($(CONFIG_PACKAGE_$(1))$(SDK)$(DEVELOPER),)
IPKGS += $(1)
compile: $$(IPKG_$(1)) $(PKG_INFO_DIR)/$(1).provides $(STAGING_DIR_ROOT)/stamp/.$(1)_installed
ifeq ($(CONFIG_PACKAGE_$(1)),y)
- .PHONY: $(PKG_INFO_DIR)/$(PKG_DIR_NAME).install.$(1)
- compile: $(PKG_INFO_DIR)/$(PKG_DIR_NAME).install.$(1)
- $(PKG_INFO_DIR)/$(PKG_DIR_NAME).install.$(1):
- @if [ -f $(PKG_INFO_DIR)/$(PKG_DIR_NAME).install.clean ]; then \
+ .PHONY: $(PKG_INSTALL_STAMP).$(1)
+ compile: $(PKG_INSTALL_STAMP).$(1)
+ $(PKG_INSTALL_STAMP).$(1):
+ if [ -f $(PKG_INSTALL_STAMP).clean ]; then \
rm -f \
- $(PKG_INFO_DIR)/$(PKG_DIR_NAME).install \
- $(PKG_INFO_DIR)/$(PKG_DIR_NAME).install.clean; \
+ $(PKG_INSTALL_STAMP) \
+ $(PKG_INSTALL_STAMP).clean; \
fi; \
- echo "$(1)" >> $(PKG_INFO_DIR)/$(PKG_DIR_NAME).install
+ echo "$(1)" >> $(PKG_INSTALL_STAMP)
endif
else
compile: $(1)-disabled