aboutsummaryrefslogtreecommitdiffstats
path: root/include/package-ipkg.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-10-22 08:57:50 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-10-22 08:57:50 +0000
commite54e2b05098a727869514e6abb05819795af567f (patch)
treeddfbbadcfaaa277a1059914ab9f0849c30953f6f /include/package-ipkg.mk
parentc52c5e1d1230d7a190baad89fecd8b68540310bb (diff)
downloadmaster-187ad058-e54e2b05098a727869514e6abb05819795af567f.tar.gz
master-187ad058-e54e2b05098a727869514e6abb05819795af567f.tar.bz2
master-187ad058-e54e2b05098a727869514e6abb05819795af567f.zip
build: only print skipped packages that were selected
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43023 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/package-ipkg.mk')
-rw-r--r--include/package-ipkg.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index b8c8cd6f99..13bb7c7d42 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -109,7 +109,7 @@ ifeq ($(DUMP),)
echo "$(1)" >> $(PKG_INSTALL_STAMP)
endif
else
- $$(info WARNING: skipping $(1) -- package not selected)
+ $(if $(CONFIG_PACKAGE_$(1)),$$(info WARNING: skipping $(1) -- package not selected))
endif
endif
endif