aboutsummaryrefslogtreecommitdiffstats
path: root/include/package-ipkg.mk
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2013-07-18 11:29:18 +0000
committerJonas Gorski <jogo@openwrt.org>2013-07-18 11:29:18 +0000
commitdd38ccf62023e76937bc4f6cf7f2e602ea7b0a98 (patch)
treeabe112b5c67342ca9147f61257eca94cc64638e1 /include/package-ipkg.mk
parent61b763d414aee61d16bc29f29670f1ac2f425422 (diff)
downloadmaster-187ad058-dd38ccf62023e76937bc4f6cf7f2e602ea7b0a98.tar.gz
master-187ad058-dd38ccf62023e76937bc4f6cf7f2e602ea7b0a98.tar.bz2
master-187ad058-dd38ccf62023e76937bc4f6cf7f2e602ea7b0a98.zip
build: print missing dependency error to stderr
Allow to see the actual error even when compiling with V=w/V=1 only. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37388 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/package-ipkg.mk')
-rw-r--r--include/package-ipkg.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 696de156cf..522a1de15f 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -64,8 +64,8 @@ ifneq ($(PKG_NAME),toolchain)
echo "$$$$FILE" >> $(PKG_INFO_DIR)/$(1).missing; \
done; \
if [ -f "$(PKG_INFO_DIR)/$(1).missing" ]; then \
- echo "Package $(1) is missing dependencies for the following libraries:"; \
- cat "$(PKG_INFO_DIR)/$(1).missing"; \
+ echo "Package $(1) is missing dependencies for the following libraries:" >&2; \
+ cat "$(PKG_INFO_DIR)/$(1).missing" >&2; \
false; \
fi; \
)