aboutsummaryrefslogtreecommitdiffstats
path: root/include/package-ipkg.mk
diff options
context:
space:
mode:
authorHamish Guthrie <hcg@openwrt.org>2012-10-19 15:34:28 +0000
committerHamish Guthrie <hcg@openwrt.org>2012-10-19 15:34:28 +0000
commita81ef914e0b41afc1dfd4292b8352e33f22dde22 (patch)
tree456cb3e98620d4ff6318a6e23ad37b6144ccda4c /include/package-ipkg.mk
parent810db7487c02e232e792c5a6dffdb4aac044615b (diff)
downloadmaster-187ad058-a81ef914e0b41afc1dfd4292b8352e33f22dde22.tar.gz
master-187ad058-a81ef914e0b41afc1dfd4292b8352e33f22dde22.tar.bz2
master-187ad058-a81ef914e0b41afc1dfd4292b8352e33f22dde22.zip
licensing: Add licensing metadata to many packages
Two new variables are introduces to many packages, namely PKG_LICENSE and PKG_LICENSE_FILES - there may be more than one license applied to packages, and these are listed in the PKG_LICENSE variable and separated by spaces. All relevant license files are also added to the PKG_LICENSE_FILES variable, also space separated. The licensing metadata is put into the bin/<platform>/packages/Packages file for later parsing. A script for that is on it's way! git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33861 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/package-ipkg.mk')
-rw-r--r--include/package-ipkg.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 665aac5d65..4ee0a96ad1 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -149,6 +149,10 @@ ifeq ($(DUMP),)
echo "Depends: $$$$DEPENDS"; \
echo "Provides: $(PROVIDES)"; \
echo "Source: $(SOURCE)"; \
+ echo "SourceFile: $(PKG_SOURCE)"; \
+ echo "SourceURL: $(PKG_SOURCE_URL)"; \
+ echo "License: $(PKG_LICENSE)"; \
+ echo "LicenseFiles: $(PKG_LICENSE_FILES)"; \
echo "Section: $(SECTION)"; \
echo "Status: unknown $(if $(filter hold,$(PKG_FLAGS)),hold,ok) not-installed"; \
echo "Essential: $(if $(filter essential,$(PKG_FLAGS)),yes,no)"; \