aboutsummaryrefslogtreecommitdiffstats
path: root/include/package-ipkg.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-01-29 21:59:17 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-01-29 21:59:17 +0000
commita22f276947dafd847e81b20034a8a1b307e078a5 (patch)
tree3b51029dea7217fff4fd014f874fd3834a0cbb5b /include/package-ipkg.mk
parente09cec721ec300f7bd4052d72894277f36eeb994 (diff)
downloadmaster-187ad058-a22f276947dafd847e81b20034a8a1b307e078a5.tar.gz
master-187ad058-a22f276947dafd847e81b20034a8a1b307e078a5.tar.bz2
master-187ad058-a22f276947dafd847e81b20034a8a1b307e078a5.zip
include: use anchored patterns for dependency checking
Anchor search pattern when testing dependencies, otherwise the check may succeed in cases where it shouldn't, e.g. when matching "udp_tunnel.ko" against "ip6_udp_tunnel.ko". Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44207 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/package-ipkg.mk')
-rw-r--r--include/package-ipkg.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 77eaeb824f..815aef093a 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -66,7 +66,7 @@ ifneq ($(PKG_NAME),toolchain)
XARGS="$(XARGS)"; \
$(SCRIPT_DIR)/gen-dependencies.sh "$$(IDIR_$(1))"; \
) | while read FILE; do \
- grep -q "$$$$FILE" $(PKG_INFO_DIR)/$(1).provides || \
+ grep -qE "^$$$$FILE$$$$" $(PKG_INFO_DIR)/$(1).provides || \
echo "$$$$FILE" >> $(PKG_INFO_DIR)/$(1).missing; \
done; \
if [ -f "$(PKG_INFO_DIR)/$(1).missing" ]; then \