aboutsummaryrefslogtreecommitdiffstats
path: root/include/package-ipkg.mk
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2011-10-26 00:49:07 +0000
committerNicolas Thill <nico@openwrt.org>2011-10-26 00:49:07 +0000
commita133a1a62bc9f0a01b5e375b37d04e1961711887 (patch)
tree50eafb4bd3e07926edf182bfb53c3e09eafd3b30 /include/package-ipkg.mk
parenta2f8409245d3430cef68e8ee20b52fd67f5ac56e (diff)
downloadmaster-187ad058-a133a1a62bc9f0a01b5e375b37d04e1961711887.tar.gz
master-187ad058-a133a1a62bc9f0a01b5e375b37d04e1961711887.tar.bz2
master-187ad058-a133a1a62bc9f0a01b5e375b37d04e1961711887.zip
include/package-ipkg.mk: fix typo
Fix a typo that caused packaging of an empty ./lib/upgrade/keep.d directory when the package supplied conffiles git-svn-id: svn://svn.openwrt.org/openwrt/trunk@28595 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/package-ipkg.mk')
-rw-r--r--include/package-ipkg.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 33b9ef8353..9eec4f26e9 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -123,7 +123,7 @@ ifeq ($(DUMP),)
for x in $$(KEEP_$(1)); do \
[ -f "$$(IDIR_$(1))/$$$$x" ] || keepfiles="$$$${keepfiles:+$$$$keepfiles }$$$$x"; \
done; \
- [ -z "$keepfiles" ] || { \
+ [ -z "$$$$keepfiles" ] || { \
mkdir -p $$(IDIR_$(1))/lib/upgrade/keep.d; \
for x in $$$$keepfiles; do echo $$$$x >> $$(IDIR_$(1))/lib/upgrade/keep.d/$(1); done; \
}; \