aboutsummaryrefslogtreecommitdiffstats
path: root/include/package-ipkg.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-04-03 02:07:59 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-04-03 02:07:59 +0000
commit8249039087290abbf0d7afb449410d2695c2bb15 (patch)
tree7adffd1d8d2d3083b817f698b35c9ae15c66dc4a /include/package-ipkg.mk
parent92066048f531f21495f4fe528d06469826dc72ce (diff)
downloadmaster-187ad058-8249039087290abbf0d7afb449410d2695c2bb15.tar.gz
master-187ad058-8249039087290abbf0d7afb449410d2695c2bb15.tar.bz2
master-187ad058-8249039087290abbf0d7afb449410d2695c2bb15.zip
build: do not use shell calls to export empty opkg control files, speeds up package build and fixes some "Argument list too long" errors
Patch by Thomas Langer from #8450 git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26431 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/package-ipkg.mk')
-rw-r--r--include/package-ipkg.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 2360ac4d4e..9cccff261a 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -28,8 +28,10 @@ IPKG_BUILD:= \
IPKG_STATE_DIR:=$(TARGET_DIR)/usr/lib/opkg
define BuildIPKGVariable
+ifdef Package/$(1)/$(2)
$(call shexport,Package/$(1)/$(2))
$(1)_COMMANDS += $(SH_FUNC) var2file "$(call shvar,Package/$(1)/$(2))" $(2);
+endif
endef
PARENL :=(