aboutsummaryrefslogtreecommitdiffstats
path: root/include/package-ipkg.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-10-24 09:24:51 +0000
committerJo-Philipp Wich <jow@openwrt.org>2014-10-24 09:24:51 +0000
commit809cc25f9d1bd203083dbaac2d549ccdebbdb5dc (patch)
tree0dd9cd178b8ae38d45bf00a04cc2f04a2c957ad3 /include/package-ipkg.mk
parent16f737c9002534673891299318b2d805c0d71dc7 (diff)
downloadmaster-187ad058-809cc25f9d1bd203083dbaac2d549ccdebbdb5dc.tar.gz
master-187ad058-809cc25f9d1bd203083dbaac2d549ccdebbdb5dc.tar.bz2
master-187ad058-809cc25f9d1bd203083dbaac2d549ccdebbdb5dc.zip
include: unbreak conffiles, postinst & prerm exports
Changeset r43017 reworked the ipkg control metadata generation but broke the export of conffiles, postinst and prerm defines. Change the code back to rely on shvar and shexport, this is required to properly output multiline contents. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43041 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/package-ipkg.mk')
-rw-r--r--include/package-ipkg.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 13bb7c7d42..77eaeb824f 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -13,10 +13,14 @@ IPKG_BUILD:= \
IPKG_STATE_DIR:=$(TARGET_DIR)/usr/lib/opkg
+# 1: package name
+# 2: variable name
+# 3: variable suffix
define BuildIPKGVariable
ifdef Package/$(1)/$(2)
$$(IPKG_$(1)) : VAR_$(2)$(3)=$$(Package/$(1)/$(2))
- $(1)_COMMANDS += echo "$$$$$(2)$(3)" > $(2)$(3);
+ $(call shexport,Package/$(1)/$(2))
+ $(1)_COMMANDS += echo "$$$$$$$$$(call shvar,Package/$(1)/$(2))" > $(2)$(3);
endif
endef