aboutsummaryrefslogtreecommitdiffstats
path: root/include/package-ipkg.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-10-03 14:37:55 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-10-03 14:37:55 +0000
commit5a73a9f898f489cea3e2e28231b261ae097051bd (patch)
tree28c03d0d4533761c7e41c9f8a4f915bbfdb604f5 /include/package-ipkg.mk
parent44d43f5e7f479f724fd3de2045a8935702ef152b (diff)
downloadmaster-187ad058-5a73a9f898f489cea3e2e28231b261ae097051bd.tar.gz
master-187ad058-5a73a9f898f489cea3e2e28231b261ae097051bd.tar.bz2
master-187ad058-5a73a9f898f489cea3e2e28231b261ae097051bd.zip
implement conditional dependencies for generating the Depends: field of ipkgs
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12836 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/package-ipkg.mk')
-rw-r--r--include/package-ipkg.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 16378a0f0e..de9798413d 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -22,6 +22,11 @@ define BuildIPKGVariable
$(1)_COMMANDS += var2file "$(call shvar,Package/$(1)/$(2))" $(2);
endef
+dep_split=$(subst :,$(space),$(1))
+dep_confvar=CONFIG_$(word 1,$(call dep_split,$(1)))
+dep_val=$(word 2,$(call dep_split,$(1)))
+filter_deps=$(foreach dep,$(1),$(if $(findstring :,$(dep)),$(if $($(call dep_confvar,$(dep))),$(call dep_val,$(dep))),$(dep)))
+
ifeq ($(DUMP),)
define BuildTarget/ipkg
IPKG_$(1):=$(PACKAGE_DIR)/$(1)_$(VERSION)_$(PKGARCH).ipk
@@ -42,7 +47,7 @@ ifeq ($(DUMP),)
endif
endif
- IDEPEND_$(1):=$$(strip $$(DEPENDS))
+ IDEPEND_$(1):=$$(call filter_deps,$$(strip $$(DEPENDS)))
$(eval $(call BuildIPKGVariable,$(1),conffiles))
$(eval $(call BuildIPKGVariable,$(1),preinst))