aboutsummaryrefslogtreecommitdiffstats
path: root/include/package-ipkg.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-06-13 11:42:17 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-06-13 11:42:17 +0000
commit2a372d147f0f06b4e2377cc7074e8950dfcfac4e (patch)
tree078280ed046f7f8533a970b2488250381a2e54ec /include/package-ipkg.mk
parent0362b77a24c5fc92f2488700f75b0f4eada36b0e (diff)
downloadmaster-187ad058-2a372d147f0f06b4e2377cc7074e8950dfcfac4e.tar.gz
master-187ad058-2a372d147f0f06b4e2377cc7074e8950dfcfac4e.tar.bz2
master-187ad058-2a372d147f0f06b4e2377cc7074e8950dfcfac4e.zip
[include] package-ipkg.sh: copy the package provides list for all virtual PROVIDES
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32332 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/package-ipkg.mk')
-rw-r--r--include/package-ipkg.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index e9bac7a23b..7ff3f6e23a 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -144,6 +144,7 @@ ifeq ($(DUMP),)
fi; \
done; \
) | sort -u > $(PKG_INFO_DIR)/$(1).provides
+ $(if $(PROVIDES),@for pkg in $(PROVIDES); do cp $(PKG_INFO_DIR)/$(1).provides $(PKG_INFO_DIR)/$$pkg.provides; done)
$(CheckDependencies)
$(RSTRIP) $$(IDIR_$(1))