aboutsummaryrefslogtreecommitdiffstats
path: root/include/package-ipkg.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-02-03 10:11:06 +0000
committerJohn Crispin <blogic@openwrt.org>2015-02-03 10:11:06 +0000
commit17a17ddc41f485b3e4b0d631528f8bd936d7d50f (patch)
tree3a8697e0c54c046e5286479e8c70233b0a690e91 /include/package-ipkg.mk
parent25b37fea13648e8b0d44d6bbf625a04fabb7b87a (diff)
downloadmaster-187ad058-17a17ddc41f485b3e4b0d631528f8bd936d7d50f.tar.gz
master-187ad058-17a17ddc41f485b3e4b0d631528f8bd936d7d50f.tar.bz2
master-187ad058-17a17ddc41f485b3e4b0d631528f8bd936d7d50f.zip
Fix possible fail to check for dependencies
Few characters in filenames (a plus sign, a dot) can be interpreted specially by grep. This can lead to the omission of missing package dependency. For example if we would have "some.file.so" then it matches also "some2file.so". -F switch off special meaning of any character and -x match against whole line. Signed-off-by: SÅ‚awomir Demeszko <s.demeszko@wireless-instruments.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44247 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/package-ipkg.mk')
-rw-r--r--include/package-ipkg.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 11edb9aeaa..b7dc0ad1e8 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -66,7 +66,7 @@ ifneq ($(PKG_NAME),toolchain)
XARGS="$(XARGS)"; \
$(SCRIPT_DIR)/gen-dependencies.sh "$$(IDIR_$(1))"; \
) | while read FILE; do \
- grep -q "^$$$$FILE$$$$" $(PKG_INFO_DIR)/$(1).provides || \
+ grep -qxF "$$$$FILE" $(PKG_INFO_DIR)/$(1).provides || \
echo "$$$$FILE" >> $(PKG_INFO_DIR)/$(1).missing; \
done; \
if [ -f "$(PKG_INFO_DIR)/$(1).missing" ]; then \