aboutsummaryrefslogtreecommitdiffstats
path: root/include/package-ipkg.mk
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2015-01-31 08:15:46 +0000
committerNicolas Thill <nico@openwrt.org>2015-01-31 08:15:46 +0000
commit1764dc90c62b80a637b5bdac02fcc286e141dc96 (patch)
tree8ca00ab5b5e1553d54c2e9cbc0ba7d1b7a3f87f7 /include/package-ipkg.mk
parent65b02ac9166b6a32d794dc4e9b435cc808ad9845 (diff)
downloadmaster-187ad058-1764dc90c62b80a637b5bdac02fcc286e141dc96.tar.gz
master-187ad058-1764dc90c62b80a637b5bdac02fcc286e141dc96.tar.bz2
master-187ad058-1764dc90c62b80a637b5bdac02fcc286e141dc96.zip
include: don't use extended regex for deps checking
Closes: #18851 Signed-off-by: Nicolas Thill <nico@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44224 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/package-ipkg.mk')
-rw-r--r--include/package-ipkg.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 815aef093a..11edb9aeaa 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -66,7 +66,7 @@ ifneq ($(PKG_NAME),toolchain)
XARGS="$(XARGS)"; \
$(SCRIPT_DIR)/gen-dependencies.sh "$$(IDIR_$(1))"; \
) | while read FILE; do \
- grep -qE "^$$$$FILE$$$$" $(PKG_INFO_DIR)/$(1).provides || \
+ grep -q "^$$$$FILE$$$$" $(PKG_INFO_DIR)/$(1).provides || \
echo "$$$$FILE" >> $(PKG_INFO_DIR)/$(1).missing; \
done; \
if [ -f "$(PKG_INFO_DIR)/$(1).missing" ]; then \