aboutsummaryrefslogtreecommitdiffstats
path: root/include/package-ipkg.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-11-22 07:08:39 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-11-22 07:08:39 +0000
commit0f48fd8058bcf04e24ce149e16cca767a3652806 (patch)
treeed3b2eca81c314c2fbcb5b4e7f4159b709630bf3 /include/package-ipkg.mk
parentfbf1d97b4a6d248b22dd6fddb09798855d8ae951 (diff)
downloadmaster-187ad058-0f48fd8058bcf04e24ce149e16cca767a3652806.tar.gz
master-187ad058-0f48fd8058bcf04e24ce149e16cca767a3652806.tar.bz2
master-187ad058-0f48fd8058bcf04e24ce149e16cca767a3652806.zip
build variants: only build opkg packages for the requested build variant (or any if no variant was specified for the package)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18464 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/package-ipkg.mk')
-rw-r--r--include/package-ipkg.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index bd4e28ce35..1ddd80a8dc 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -36,6 +36,7 @@ ifeq ($(DUMP),)
IDIR_$(1):=$(PKG_BUILD_DIR)/ipkg-$(PKGARCH)/$(1)
INFO_$(1):=$(IPKG_STATE_DIR)/info/$(1).list
+ ifeq ($(if $(VARIANT),$(BUILD_VARIANT)),$(VARIANT))
ifdef Package/$(1)/install
ifneq ($(CONFIG_PACKAGE_$(1))$(SDK)$(DEVELOPER),)
compile: $$(IPKG_$(1)) $(STAGING_DIR_ROOT)/stamp/.$(1)_installed
@@ -49,6 +50,7 @@ ifeq ($(DUMP),)
@echo "WARNING: skipping $(1) -- package not selected"
endif
endif
+ endif
IDEPEND_$(1):=$$(call filter_deps,$$(DEPENDS))