aboutsummaryrefslogtreecommitdiffstats
path: root/include/package-dumpinfo.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-10-26 16:57:33 +0000
committerJohn Crispin <blogic@openwrt.org>2014-10-26 16:57:33 +0000
commitef7634e29e01793325998ecb32cb3541fb423109 (patch)
treee6e048f580022ead70c56842c4ad3fa04b9b9622 /include/package-dumpinfo.mk
parent70fa8d00c06da8560aa7f4692b5366498808b9ad (diff)
downloadmaster-187ad058-ef7634e29e01793325998ecb32cb3541fb423109.tar.gz
master-187ad058-ef7634e29e01793325998ecb32cb3541fb423109.tar.bz2
master-187ad058-ef7634e29e01793325998ecb32cb3541fb423109.zip
generate list of license information for packages
Many packages define already metadata about their license (PKG_LICENSE), but this is only included in the ipk files. This change allows to create the information also on the build-host, to get an overview on the used licenses. In the full list, also all packages without this info are shown Signed-off-by: Thomas Langer <thomas.langer@lantiq.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43070 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/package-dumpinfo.mk')
-rw-r--r--include/package-dumpinfo.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/include/package-dumpinfo.mk b/include/package-dumpinfo.mk
index 26c8d3199d..b6e2f0f794 100644
--- a/include/package-dumpinfo.mk
+++ b/include/package-dumpinfo.mk
@@ -45,7 +45,9 @@ Title: $(TITLE)
Maintainer: $(MAINTAINER)
$(if $(USERID),Require-User: $(USERID)
)Source: $(PKG_SOURCE)
-Type: $(if $(Package/$(1)/targets),$(Package/$(1)/targets),$(if $(PKG_TARGETS),$(PKG_TARGETS),ipkg))
+$(if $(PKG_LICENSE),License: $(PKG_LICENSE)
+)$(if $(PKG_LICENSE_FILES),LicenseFiles: $(PKG_LICENSE_FILES)
+)Type: $(if $(Package/$(1)/targets),$(Package/$(1)/targets),$(if $(PKG_TARGETS),$(PKG_TARGETS),ipkg))
$(if $(KCONFIG),Kernel-Config: $(KCONFIG)
)$(if $(BUILDONLY),Build-Only: $(BUILDONLY)
)$(if $(HIDDEN),Hidden: $(HIDDEN)