aboutsummaryrefslogtreecommitdiffstats
path: root/include/package-dumpinfo.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-10-17 22:11:21 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-10-17 22:11:21 +0000
commitb57af5044a8f3764b1f63504525be6e843b36ccc (patch)
treec7c41c04b9c3f7c75ccdc39eab64e28f5cf2bce2 /include/package-dumpinfo.mk
parent5abfaa17c9b892ab0512f42f330fb669ef82ac11 (diff)
downloadmaster-187ad058-b57af5044a8f3764b1f63504525be6e843b36ccc.tar.gz
master-187ad058-b57af5044a8f3764b1f63504525be6e843b36ccc.tar.bz2
master-187ad058-b57af5044a8f3764b1f63504525be6e843b36ccc.zip
add experimental support for a new menuconfig submenu "Package features".
allows selection between multiple packages providing the same feature, which affects dependencies of other packages. will be used e.g. for choosing between DirectFB and X.org for libraries like GTK2 git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18056 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/package-dumpinfo.mk')
-rw-r--r--include/package-dumpinfo.mk30
1 files changed, 28 insertions, 2 deletions
diff --git a/include/package-dumpinfo.mk b/include/package-dumpinfo.mk
index db8d9c11ca..f48f31507a 100644
--- a/include/package-dumpinfo.mk
+++ b/include/package-dumpinfo.mk
@@ -22,7 +22,7 @@ define Config
preconfig_$$(1) += $(1)
endef
-define Dumpinfo
+define Dumpinfo/Package
$(info Package: $(1)
$(if $(MENU),Menu: $(MENU)
)$(if $(SUBMENU),Submenu: $(SUBMENU)
@@ -51,5 +51,31 @@ $(Package/$(1)/config)
@@
)$(foreach pc,$(preconfig_$(1)),
$(Preconfig/$(pc))))
- endef
+endef
+
+define Feature/Default
+ TARGET_NAME:=
+ TARGET_TITLE:=
+ PRIORITY:=
+ NAME:=
+endef
+
+define Feature
+ $(eval $(Feature/Default))
+ $(eval $(Feature/$(1)))
+ $(if $(DUMP),$(call Dumpinfo/Feature,$(1)))
+endef
+
+define Dumpinfo/Feature
+$(info Feature: $(TARGET_NAME)_$(1)
+Target-Name: $(TARGET_NAME)
+Target-Title: $(TARGET_TITLE)
+Feature-Name: $(NAME)
+$(if $(PRIORITY),Feature-Priority: $(PRIORITY)
+)Feature-Description:
+$(Feature/$(1)/description)
+@@
+)
+endef
+
endif