aboutsummaryrefslogtreecommitdiffstats
path: root/include/package-defaults.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-20 16:50:50 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-20 16:50:50 +0000
commitec6b4b35c611685628695ec10469557cb30fb07f (patch)
treed482449569a8eedaf5b8a1a20681504befd9bda2 /include/package-defaults.mk
parentd6091cee771ba59a6ba0b89721c0815ad445f569 (diff)
downloadmaster-187ad058-ec6b4b35c611685628695ec10469557cb30fb07f.tar.gz
master-187ad058-ec6b4b35c611685628695ec10469557cb30fb07f.tar.bz2
master-187ad058-ec6b4b35c611685628695ec10469557cb30fb07f.zip
build: add optional dependency on libssp to all non-kernel packages
When enabling SSP_SUPPORT, a lot of packages fail during compile phase with the following error: Package X is missing dependencies for the following libraries: libssp.so.0 This can be solved by adding an optional dependency on libssp to all those packages, but as there are quite a few packages both in OpenWrt core and in the package repository, it might make sense to add this optional dependency to all non-kernel packages, instead of polluting lots of package dependency lines with it. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44911 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/package-defaults.mk')
-rw-r--r--include/package-defaults.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/package-defaults.mk b/include/package-defaults.mk
index a94f2a4c06..9567e04a7a 100644
--- a/include/package-defaults.mk
+++ b/include/package-defaults.mk
@@ -5,7 +5,7 @@
# See /LICENSE for more information.
#
-PKG_DEFAULT_DEPENDS = +libc +USE_GLIBC:librt +USE_GLIBC:libpthread
+PKG_DEFAULT_DEPENDS = +libc +SSP_SUPPORT:libssp +USE_GLIBC:librt +USE_GLIBC:libpthread
ifneq ($(PKG_NAME),toolchain)
PKG_FIXUP_DEPENDS = $(if $(filter kmod-%,$(1)),$(2),$(PKG_DEFAULT_DEPENDS) $(filter-out $(PKG_DEFAULT_DEPENDS),$(2)))