aboutsummaryrefslogtreecommitdiffstats
path: root/include/package-defaults.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-06-03 06:16:08 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-06-03 06:16:08 +0000
commit414e3ef71af42ec5a4c18ff0be41f7b794ab28e7 (patch)
treeeed2fdcff73a7374bac56a637ae02b5362877ec7 /include/package-defaults.mk
parent304696e31df4478708f59f2c81433339e4634e7f (diff)
downloadmaster-187ad058-414e3ef71af42ec5a4c18ff0be41f7b794ab28e7.tar.gz
master-187ad058-414e3ef71af42ec5a4c18ff0be41f7b794ab28e7.tar.bz2
master-187ad058-414e3ef71af42ec5a4c18ff0be41f7b794ab28e7.zip
Add quilt integration for packages
make package/<package>-prepare QUILT=1 will apply all patches using quilt Autorebuild will be disabled, so that you can edit all patches in the build dir. When you're done editing patches and everything works, you can call: make package/<package>-refresh That will copy the updated patches from quilt into package/<package>/patches, and remove all old patches. Before the patches are overwritten, the correct order of the patches is verified ('cat series' is compared against 'sort series'). git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7471 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/package-defaults.mk')
-rw-r--r--include/package-defaults.mk5
1 files changed, 2 insertions, 3 deletions
diff --git a/include/package-defaults.mk b/include/package-defaults.mk
index 57f5ed7ef4..16d9ae0027 100644
--- a/include/package-defaults.mk
+++ b/include/package-defaults.mk
@@ -33,12 +33,11 @@ define Package/Default
DESCRIPTION:=
endef
+Build/Patch:=$(Build/Patch/Default)
ifneq ($(strip $(PKG_UNPACK)),)
define Build/Prepare/Default
$(PKG_UNPACK)
- @if [ -d ./patches -a "$$$$(ls ./patches | wc -l)" -gt 0 ]; then \
- $(PATCH) $(PKG_BUILD_DIR) ./patches; \
- fi
+ $(Build/Patch)
endef
endif