aboutsummaryrefslogtreecommitdiffstats
path: root/include/package-debug.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-01-13 03:21:25 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-01-13 03:21:25 +0000
commite12489a3e2f9b970129b82697904f18ce6e11de0 (patch)
treeb2f98ad66d9698b8c9607f426f420d92f11576bf /include/package-debug.mk
parentaf3f632c320b0c259e0976fca908fddce735abe9 (diff)
downloadmaster-187ad058-e12489a3e2f9b970129b82697904f18ce6e11de0.tar.gz
master-187ad058-e12489a3e2f9b970129b82697904f18ce6e11de0.tar.bz2
master-187ad058-e12489a3e2f9b970129b82697904f18ce6e11de0.zip
add support for an optional staging directory for debug binaries
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14018 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/package-debug.mk')
-rw-r--r--include/package-debug.mk26
1 files changed, 26 insertions, 0 deletions
diff --git a/include/package-debug.mk b/include/package-debug.mk
new file mode 100644
index 0000000000..2a85bfebb8
--- /dev/null
+++ b/include/package-debug.mk
@@ -0,0 +1,26 @@
+#
+# Copyright (C) 2006,2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+ifeq ($(DUMP),)
+ define BuildTarget/debug
+
+ DEBUG_STAMP_$(1) := $(DEBUG_DIR)/stamp/$(1)
+
+ ifdef Package/$(1)/install
+ ifneq ($(CONFIG_PACKAGE_$(1))$(SDK)$(DEVELOPER),)
+ compile: $$(DEBUG_STAMP_$(1))
+ endif
+ endif
+
+ $$(DEBUG_STAMP_$(1)): $(PKG_BUILD_DIR)/.built
+ mkdir -p $(DEBUG_DIR)/stamp
+ $(call Package/$(1)/install,$(DEBUG_DIR))
+ touch $$(DEBUG_STAMP_$(1))
+
+
+ endef
+endif