aboutsummaryrefslogtreecommitdiffstats
path: root/include/package-bin.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-09-29 01:21:56 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-09-29 01:21:56 +0000
commit3eda02f389438652720d82e60392028d43478e8d (patch)
treef98e2082480fdb704253335dac8fd6d0b7376559 /include/package-bin.mk
parentccff8348deb578ad232ea0c7fc6ae92e8d22f2de (diff)
downloadmaster-187ad058-3eda02f389438652720d82e60392028d43478e8d.tar.gz
master-187ad058-3eda02f389438652720d82e60392028d43478e8d.tar.bz2
master-187ad058-3eda02f389438652720d82e60392028d43478e8d.zip
add a packaging method that installs files into a subdirectory of bin/ instead of an ipkg
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9060 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/package-bin.mk')
-rw-r--r--include/package-bin.mk31
1 files changed, 31 insertions, 0 deletions
diff --git a/include/package-bin.mk b/include/package-bin.mk
new file mode 100644
index 0000000000..6ee7aed621
--- /dev/null
+++ b/include/package-bin.mk
@@ -0,0 +1,31 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+ifeq ($(DUMP),)
+ define BuildTarget/bin
+ ifdef Package/$(1)/install
+ ifneq ($(CONFIG_PACKAGE_$(1))$(SDK)$(DEVELOPER),)
+ compile: install-bin-$(1)
+ else
+ compile: $(1)-disabled
+ $(1)-disabled:
+ @echo "WARNING: skipping $(1) -- package not selected"
+ endif
+ endif
+
+ install-bin-$(1): $(STAMP_BUILT)
+ rm -rf $(BIN_DIR)/$(1)
+ $(INSTALL_DIR) $(BIN_DIR)/$(1)
+ $(call Package/$(1)/install,$(BIN_DIR)/$(1))
+
+ clean-$(1):
+ rm -rf $(BIN_DIR)/$(1)
+
+ clean: clean-$(1)
+ .PHONY: install-bin-$(1)
+ endef
+endif