aboutsummaryrefslogtreecommitdiffstats
path: root/include/package-bin.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-05-15 15:57:00 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-05-15 15:57:00 +0000
commit21316a5d49245d1224371f5b438c484c0da16e1d (patch)
treee321b8333cb87085a2670b3a277ee0259a12393e /include/package-bin.mk
parenta39655c7fcc8e45815b07e88f254b7f831e56dee (diff)
downloadmaster-187ad058-21316a5d49245d1224371f5b438c484c0da16e1d.tar.gz
master-187ad058-21316a5d49245d1224371f5b438c484c0da16e1d.tar.bz2
master-187ad058-21316a5d49245d1224371f5b438c484c0da16e1d.zip
only build bin packages for the selected build variants (same behaviour as with ipkg builds)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21455 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/package-bin.mk')
-rw-r--r--include/package-bin.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/package-bin.mk b/include/package-bin.mk
index 6ee7aed621..96c1aeffcf 100644
--- a/include/package-bin.mk
+++ b/include/package-bin.mk
@@ -7,6 +7,7 @@
ifeq ($(DUMP),)
define BuildTarget/bin
+ ifeq ($(if $(VARIANT),$(BUILD_VARIANT)),$(VARIANT))
ifdef Package/$(1)/install
ifneq ($(CONFIG_PACKAGE_$(1))$(SDK)$(DEVELOPER),)
compile: install-bin-$(1)
@@ -16,6 +17,7 @@ ifeq ($(DUMP),)
@echo "WARNING: skipping $(1) -- package not selected"
endif
endif
+ endif
install-bin-$(1): $(STAMP_BUILT)
rm -rf $(BIN_DIR)/$(1)