aboutsummaryrefslogtreecommitdiffstats
path: root/include/netfilter.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-10-18 20:39:07 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-10-18 20:39:07 +0000
commit94d6c4e9ca76e988f534995815061973e6b262b9 (patch)
treeb4a081a4a742a624480fa878261c33248152438c /include/netfilter.mk
parent4701c8448b657871b8692fbb172bae8c64c0cf12 (diff)
downloadmaster-187ad058-94d6c4e9ca76e988f534995815061973e6b262b9.tar.gz
master-187ad058-94d6c4e9ca76e988f534995815061973e6b262b9.tar.bz2
master-187ad058-94d6c4e9ca76e988f534995815061973e6b262b9.zip
[include] netfilter: workaround a userspace/kernel mismatch on Linux 2.6.35 and later
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23521 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/netfilter.mk')
-rw-r--r--include/netfilter.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/include/netfilter.mk b/include/netfilter.mk
index 5ec7df6bf5..35f46de86e 100644
--- a/include/netfilter.mk
+++ b/include/netfilter.mk
@@ -135,8 +135,13 @@ $(eval $(call nf_add,IPT_IPOPT,CONFIG_NETFILTER_XT_TARGET_CLASSIFY, $(P_XT)xt_CL
$(eval $(call nf_add,IPT_IPOPT,CONFIG_IP_NF_MATCH_DSCP, $(P_V4)ipt_dscp))
$(eval $(call nf_add,IPT_IPOPT,CONFIG_IP_NF_TARGET_ECN, $(P_V4)ipt_ECN))
$(eval $(call nf_add,IPT_IPOPT,CONFIG_IP_NF_TARGET_MARK, $(P_V4)ipt_MARK))
+
+# XXX: 2.6.35+ has xt_MARK.ko merged into xt_mark.ko, userspace is still separate
ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.35)),1)
- $(eval $(call nf_add,IPT_IPOPT,CONFIG_NETFILTER_XT_TARGET_MARK, $(P_XT)xt_mark))
+ # kernel: xt_mark.ko
+ $(eval $(if $(NF_KMOD),$(call nf_add,IPT_IPOPT,CONFIG_NETFILTER_XT_TARGET_MARK, $(P_XT)xt_mark)))
+ # userland: xt_MARK.so
+ $(eval $(if $(NF_KMOD),,$(call nf_add,IPT_IPOPT,CONFIG_NETFILTER_XT_TARGET_MARK, $(P_XT)xt_MARK)))
else
$(eval $(call nf_add,IPT_IPOPT,CONFIG_NETFILTER_XT_TARGET_MARK, $(P_XT)xt_MARK))
endif