aboutsummaryrefslogtreecommitdiffstats
path: root/include/netfilter.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-07-17 08:47:44 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-07-17 08:47:44 +0000
commit891fd980a3170f4b4c4daad2755789c8da1ac40a (patch)
tree6e00f0bf22042ad15a5574e8b2d169c2b3098235 /include/netfilter.mk
parent979eceef1cce1fcda3e162b27ada49bf5cf7163d (diff)
downloadmaster-187ad058-891fd980a3170f4b4c4daad2755789c8da1ac40a.tar.gz
master-187ad058-891fd980a3170f4b4c4daad2755789c8da1ac40a.tar.bz2
master-187ad058-891fd980a3170f4b4c4daad2755789c8da1ac40a.zip
Add ipt_random module
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8014 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/netfilter.mk')
-rw-r--r--include/netfilter.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/include/netfilter.mk b/include/netfilter.mk
index 51f72fb9d3..ad65f885fe 100644
--- a/include/netfilter.mk
+++ b/include/netfilter.mk
@@ -71,6 +71,9 @@ IPT_IPOPT-$(CONFIG_IP_NF_MATCH_MARK) += $(P_V4)ipt_mark
IPT_IPOPT-$(CONFIG_NETFILTER_XT_MATCH_MARK) += $(P_XT)xt_mark
IPT_IPOPT-$(CONFIG_IP_NF_TARGET_MARK) += $(P_V4)ipt_MARK
IPT_IPOPT-$(CONFIG_NETFILTER_XT_TARGET_MARK) += $(P_XT)xt_MARK
+ifeq ($(CONFIG_LINUX_2_4),y)
+IPT_IPOPT-$(CONFIG_NETFILTER_XT_TARGET_MARK) += $(P_V4)ipt_random
+endif
IPT_IPOPT-$(CONFIG_IP_NF_MATCH_TCPMSS) += $(P_V4)ipt_tcpmss
IPT_IPOPT-$(CONFIG_NETFILTER_XT_MATCH_TCPMSS) += $(P_XT)xt_tcpmss
IPT_IPOPT-$(CONFIG_IP_NF_TARGET_TCPMSS) += $(P_V4)ipt_TCPMSS