aboutsummaryrefslogtreecommitdiffstats
path: root/include/netfilter.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-03-05 20:24:22 +0000
committerJohn Crispin <blogic@openwrt.org>2015-03-05 20:24:22 +0000
commit54ed570f694cd36a354dd81dc03d1411f2bb7d35 (patch)
treeab72b58e1e5501cca0acb05357276d049a42304e /include/netfilter.mk
parent0d1eaa903d0742d0088fa03cb4ee9d58313f5c57 (diff)
downloadmaster-187ad058-54ed570f694cd36a354dd81dc03d1411f2bb7d35.tar.gz
master-187ad058-54ed570f694cd36a354dd81dc03d1411f2bb7d35.tar.bz2
master-187ad058-54ed570f694cd36a354dd81dc03d1411f2bb7d35.zip
netfilter: fix nf_nat_redirect dependencies for 3.19 and 4.0
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44598 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/netfilter.mk')
-rw-r--r--include/netfilter.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/netfilter.mk b/include/netfilter.mk
index ed63b0b3dd..e663ea544c 100644
--- a/include/netfilter.mk
+++ b/include/netfilter.mk
@@ -183,6 +183,7 @@ $(eval $(if $(NF_KMOD),$(call nf_add,NF_NAT6,CONFIG_NF_NAT_IPV6, $(P_V6)nf_nat_i
$(eval $(if $(NF_KMOD),$(call nf_add,IPT_NAT,CONFIG_NF_NAT, $(P_XT)xt_nat, ge 3.7.0),))
$(eval $(if $(NF_KMOD),$(call nf_add,IPT_NAT,CONFIG_NETFILTER_XT_NAT, $(P_XT)xt_nat, ge 3.18.0),))
$(eval $(if $(NF_KMOD),$(call nf_add,IPT_NAT,CONFIG_NF_NAT, $(P_V4)iptable_nat, lt 3.7.0),))
+$(eval $(if $(NF_KMOD),$(call nf_add,IPT_NAT,CONFIG_NF_NAT, $(P_XT)nf_nat_redirect, ge 3.19.0),))
$(eval $(if $(NF_KMOD),$(call nf_add,IPT_NAT,CONFIG_NF_NAT_IPV4, $(P_V4)iptable_nat, ge 3.7.0),))
$(eval $(if $(NF_KMOD),$(call nf_add,IPT_NAT,CONFIG_IP_NF_NAT, $(P_V4)iptable_nat, ge 3.16.0),))
$(eval $(if $(NF_KMOD),$(call nf_add,IPT_NAT6,CONFIG_NF_NAT_IPV6, $(P_V6)ip6table_nat, ge 3.7.0),))