aboutsummaryrefslogtreecommitdiffstats
path: root/include/netfilter.mk
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2013-09-03 06:29:46 +0000
committerSteven Barth <steven@midlink.org>2013-09-03 06:29:46 +0000
commit4973dc115388e58f52b34ed4a1594716b085a302 (patch)
treef16c4efab90d7317aa087f971683e84adff21811 /include/netfilter.mk
parent0977e4452ff1d5716a787cb54b0a584980aee259 (diff)
downloadmaster-187ad058-4973dc115388e58f52b34ed4a1594716b085a302.tar.gz
master-187ad058-4973dc115388e58f52b34ed4a1594716b085a302.tar.bz2
master-187ad058-4973dc115388e58f52b34ed4a1594716b085a302.zip
Fix IPv6 NAT breaking older kernels
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37891 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/netfilter.mk')
-rw-r--r--include/netfilter.mk2
1 files changed, 0 insertions, 2 deletions
diff --git a/include/netfilter.mk b/include/netfilter.mk
index fe31091b6c..305f28e087 100644
--- a/include/netfilter.mk
+++ b/include/netfilter.mk
@@ -170,14 +170,12 @@ $(eval $(if $(NF_KMOD),,$(call nf_add,IPT_NAT6,CONFIG_IP6_NF_TARGET_NPT, ip6t_DN
$(eval $(call nf_add,IPT_NAT,CONFIG_IP_NF_TARGET_MASQUERADE, $(P_V4)ipt_MASQUERADE))
$(eval $(call nf_add,IPT_NAT,CONFIG_IP_NF_TARGET_REDIRECT, $(P_XT)xt_REDIRECT, ge 3.7.0))
$(eval $(call nf_add,IPT_NAT,CONFIG_IP_NF_TARGET_REDIRECT, $(P_V4)ipt_REDIRECT, lt 3.7.0))
-$(eval $(call nf_add,IPT_NAT6,CONFIG_IP_NF_TARGET_REDIRECT, $(P_V4)ip6t_REDIRECT, lt 3.8.0))
# nat-extra
$(eval $(call nf_add,IPT_NAT_EXTRA,CONFIG_IP_NF_TARGET_NETMAP, $(P_XT)xt_NETMAP, ge 3.7.0))
$(eval $(call nf_add,IPT_NAT_EXTRA,CONFIG_IP_NF_TARGET_NETMAP, $(P_V4)ipt_NETMAP, lt 3.7.0))
-$(eval $(call nf_add,IPT_NAT6,CONFIG_IP_NF_TARGET_NETMAP, $(P_V6)ip6t_NETMAP, lt 3.8.0))
# nathelper