aboutsummaryrefslogtreecommitdiffstats
path: root/include/netfilter.mk
diff options
context:
space:
mode:
authorZoltan Herpai <wigyori@uid0.hu>2016-11-10 16:12:32 +0100
committerGitHub <noreply@github.com>2016-11-10 16:12:32 +0100
commit2f73d1f5e5cd7c5e98fa838e61bfa4030ad0fc40 (patch)
tree5447a8334b4cac983581d4ab9f73682c23b14f67 /include/netfilter.mk
parentcedab88a4379aebeb3dbd7cc420bb4a13874eef1 (diff)
parentdc5d9e714a15b8130f0d2a79f54d4f7132f39a28 (diff)
downloadmaster-187ad058-2f73d1f5e5cd7c5e98fa838e61bfa4030ad0fc40.tar.gz
master-187ad058-2f73d1f5e5cd7c5e98fa838e61bfa4030ad0fc40.tar.bz2
master-187ad058-2f73d1f5e5cd7c5e98fa838e61bfa4030ad0fc40.zip
Merge pull request #199 from seragh/owrt-firewall-2016-11-06
firewall version bump to 2016-11-06 and xt_id removal
Diffstat (limited to 'include/netfilter.mk')
-rw-r--r--include/netfilter.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/include/netfilter.mk b/include/netfilter.mk
index 0a921f5d1c..2882d25fd7 100644
--- a/include/netfilter.mk
+++ b/include/netfilter.mk
@@ -38,13 +38,12 @@ $(eval $(if $(NF_KMOD),$(call nf_add,IPT_CORE,CONFIG_IP_NF_FILTER, $(P_V4)iptabl
$(eval $(if $(NF_KMOD),$(call nf_add,IPT_CORE,CONFIG_IP_NF_MANGLE, $(P_V4)iptable_mangle),))
# userland only
-$(eval $(if $(NF_KMOD),,$(call nf_add,IPT_CORE,CONFIG_IP_NF_IPTABLES, xt_standard ipt_icmp xt_tcp xt_udp xt_comment xt_id xt_set xt_SET)))
+$(eval $(if $(NF_KMOD),,$(call nf_add,IPT_CORE,CONFIG_IP_NF_IPTABLES, xt_standard ipt_icmp xt_tcp xt_udp xt_comment xt_set xt_SET)))
$(eval $(call nf_add,IPT_CORE,CONFIG_NETFILTER_XT_MATCH_LIMIT, $(P_XT)xt_limit))
$(eval $(call nf_add,IPT_CORE,CONFIG_NETFILTER_XT_MATCH_MAC, $(P_XT)xt_mac))
$(eval $(call nf_add,IPT_CORE,CONFIG_NETFILTER_XT_MATCH_MULTIPORT, $(P_XT)xt_multiport))
$(eval $(call nf_add,IPT_CORE,CONFIG_NETFILTER_XT_MATCH_COMMENT, $(P_XT)xt_comment))
-$(eval $(call nf_add,IPT_CORE,CONFIG_NETFILTER_XT_MATCH_ID, $(P_XT)xt_id))
#cluster
$(eval $(call nf_add,IPT_CLUSTER,CONFIG_NETFILTER_XT_MATCH_CLUSTER, $(P_XT)xt_cluster))