aboutsummaryrefslogtreecommitdiffstats
path: root/include/netfilter.mk
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2007-09-03 08:58:14 +0000
committerNicolas Thill <nico@openwrt.org>2007-09-03 08:58:14 +0000
commit2750423a702eac91d17015e541e321c657c72f18 (patch)
tree29fc1ebb2e89d2e529607ed463481241e55d09ce /include/netfilter.mk
parent05a46c716e24adb817dd5e41ebdb0308ec6b78b2 (diff)
downloadmaster-187ad058-2750423a702eac91d17015e541e321c657c72f18.tar.gz
master-187ad058-2750423a702eac91d17015e541e321c657c72f18.tar.bz2
master-187ad058-2750423a702eac91d17015e541e321c657c72f18.zip
require all CONFIG_* symbols listed in its KCONFIG to be set to m in order to actually build a kmod package, tweak and fix kernel package definitions.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8591 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/netfilter.mk')
-rw-r--r--include/netfilter.mk13
1 files changed, 8 insertions, 5 deletions
diff --git a/include/netfilter.mk b/include/netfilter.mk
index 49ffefbad6..f11deacbd1 100644
--- a/include/netfilter.mk
+++ b/include/netfilter.mk
@@ -12,17 +12,20 @@ P_XT:=netfilter/
endif
define nf_add
-$(1)-$$($(2)) += $(3)
-KCONFIG_$(1) += $(2)
+ $(1)-$$($(2)) += $(3)
+ ifeq ($$($(2)),m)
+ KCONFIG_$(1) += $(2)
+ endif
endef
+
IPT_CONNTRACK-m :=
-$(eval $(call nf_add,IPT_CONNTRACK,CONFIG_IP_NF_MATCH_CONNMARK, $(P_V4)ipt_connmark))
-$(eval $(call nf_add,IPT_CONNTRACK,CONFIG_IP_NF_TARGET_CONNMARK, $(P_V4)ipt_CONNMARK))
-$(eval $(call nf_add,IPT_CONNTRACK,CONFIG_IP_NF_MATCH_CONNTRACK, $(P_V4)ipt_conntrack))
$(eval $(call nf_add,IPT_CONNTRACK,CONFIG_IP_NF_MATCH_HELPER, $(P_V4)ipt_helper))
$(eval $(call nf_add,IPT_CONNTRACK,CONFIG_IP_NF_MATCH_STATE, $(P_V4)ipt_state))
+$(eval $(call nf_add,IPT_CONNTRACK,CONFIG_IP_NF_MATCH_CONNMARK, $(P_V4)ipt_connmark))
$(eval $(call nf_add,IPT_CONNTRACK,CONFIG_NETFILTER_XT_MATCH_CONNMARK, $(P_XT)xt_connmark))
+$(eval $(call nf_add,IPT_CONNTRACK,CONFIG_IP_NF_TARGET_CONNMARK, $(P_V4)ipt_CONNMARK))
$(eval $(call nf_add,IPT_CONNTRACK,CONFIG_NETFILTER_XT_TARGET_CONNMARK, $(P_XT)xt_CONNMARK))
+$(eval $(call nf_add,IPT_CONNTRACK,CONFIG_IP_NF_MATCH_CONNTRACK, $(P_V4)ipt_conntrack))
$(eval $(call nf_add,IPT_CONNTRACK,CONFIG_NETFILTER_XT_MATCH_CONNTRACK, $(P_XT)xt_conntrack))
$(eval $(call nf_add,IPT_CONNTRACK,CONFIG_NETFILTER_XT_MATCH_HELPER, $(P_XT)xt_helper))
$(eval $(call nf_add,IPT_CONNTRACK,CONFIG_NETFILTER_XT_MATCH_STATE, $(P_XT)xt_state))