aboutsummaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-02-23 14:52:50 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-02-23 14:52:50 +0000
commitf06ef1e70657491cd486ccc7e81ec3a98b0a25dd (patch)
treea9552df28c93a793c7d7f598faeaa21b219cf7f0 /include/kernel.mk
parentcc289092b23a5bcee878390e7d2aa5558fc9a4b9 (diff)
downloadmaster-187ad058-f06ef1e70657491cd486ccc7e81ec3a98b0a25dd.tar.gz
master-187ad058-f06ef1e70657491cd486ccc7e81ec3a98b0a25dd.tar.bz2
master-187ad058-f06ef1e70657491cd486ccc7e81ec3a98b0a25dd.zip
always dereference symbolic links when copying kernel modules into the packaging directory (fixes alsa build, patch from #1392)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6350 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 1f34f00ca4..4cf0e7a72d 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -99,7 +99,7 @@ define KernelPackage
ifneq ($(strip $(FILES)),)
define Package/kmod-$(1)/install
mkdir -p $$(1)/lib/modules/$(LINUX_VERSION)
- $(CP) $$(FILES) $$(1)/lib/modules/$(LINUX_VERSION)/
+ $(CP) -L $$(FILES) $$(1)/lib/modules/$(LINUX_VERSION)/
$(call ModuleAutoLoad,$(1),$$(1),$(AUTOLOAD))
$(call KernelPackage/$(1)/install,$$(1))
endef