aboutsummaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2016-01-24 15:36:05 +0000
committerJo-Philipp Wich <jow@openwrt.org>2016-01-24 15:36:05 +0000
commitc18a81fd6d9fffb0da4f81e557f79120c1592c89 (patch)
treee7fda7faf2c757e86ec6811f74b28ac152d26950 /include/kernel.mk
parentd49ca69e9141b4414557807f7c56cc408156b54d (diff)
downloadmaster-187ad058-c18a81fd6d9fffb0da4f81e557f79120c1592c89.tar.gz
master-187ad058-c18a81fd6d9fffb0da4f81e557f79120c1592c89.tar.bz2
master-187ad058-c18a81fd6d9fffb0da4f81e557f79120c1592c89.zip
include: group kmod ipk files into a "kernel" subdirectory
This is useful to just use the kmods from an official build while supplying base packages from a custom feed or the other way around; for just overriding the kmods with a local repo while using official repos for the rest. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48475 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 57185c5fd3..3fa9b89c20 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -155,6 +155,7 @@ define KernelPackage
DESCRIPTION:=$(DESCRIPTION)
EXTRA_DEPENDS:=kernel (=$(LINUX_VERSION)-$(LINUX_RELEASE)-$(LINUX_VERMAGIC))
VERSION:=$(LINUX_VERSION)$(if $(PKG_VERSION),+$(PKG_VERSION))-$(if $(PKG_RELEASE),$(PKG_RELEASE),$(LINUX_RELEASE))
+ PACKAGE_SUBDIR:=kernel
$(call KernelPackage/$(1))
$(call KernelPackage/$(1)/$(BOARD))
endef