aboutsummaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2011-08-09 12:19:38 +0000
committerJonas Gorski <jogo@openwrt.org>2011-08-09 12:19:38 +0000
commitc025c5e99da524b1bb8fc9bdf00836f4e7402d96 (patch)
tree317f95c1a37dcc8665b366fd0a07d3f13fc1d75b /include/kernel.mk
parent47a0551d87304284d0e979914fb17397a88d5ea1 (diff)
downloadmaster-187ad058-c025c5e99da524b1bb8fc9bdf00836f4e7402d96.tar.gz
master-187ad058-c025c5e99da524b1bb8fc9bdf00836f4e7402d96.tar.bz2
master-187ad058-c025c5e99da524b1bb8fc9bdf00836f4e7402d96.zip
include/kernel.mk: fix download path for linux 3.x
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27939 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 020779fd63..4744e09ef6 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -48,7 +48,11 @@ else
LINUX_SOURCE:=linux-$(LINUX_VERSION).tar.bz2
TESTING:=$(if $(findstring -rc,$(LINUX_VERSION)),/testing,)
ifeq ($(call qstrip,$(CONFIG_EXTERNAL_KERNEL_TREE)),)
- LINUX_SITE:=@KERNEL/linux/kernel/v$(KERNEL)$(TESTING)
+ ifeq ($(word 1,$(subst ., ,$(KERNEL_BASE))),3)
+ LINUX_SITE:=@KERNEL/linux/kernel/v3.x$(TESTING)
+ else
+ LINUX_SITE:=@KERNEL/linux/kernel/v$(KERNEL)$(TESTING)
+ endif
endif
ifneq ($(TARGET_BUILD),1)