aboutsummaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-01-29 15:51:05 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-01-29 15:51:05 +0000
commitb882a8cd430447a6be6e124c05e1c77f609e2439 (patch)
tree35727be94c92ccc0ba1ad056ad632eff071f9100 /include/kernel.mk
parent22a8ac28165ab25b5357b57bba5262f6b409910b (diff)
downloadmaster-187ad058-b882a8cd430447a6be6e124c05e1c77f609e2439.tar.gz
master-187ad058-b882a8cd430447a6be6e124c05e1c77f609e2439.tar.bz2
master-187ad058-b882a8cd430447a6be6e124c05e1c77f609e2439.zip
include: apply version filter on kmod file list
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44190 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index dd6c867ea0..9fb4896d0c 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -174,7 +174,7 @@ $(call KernelPackage/$(1)/config)
ifneq ($(if $(filter-out %=y %=n %=m,$(KCONFIG)),$(filter m y,$(foreach c,$(filter-out %=y %=n %=m,$(KCONFIG)),$($(c)))),.),)
ifneq ($(if $(SDK),$(filter-out $(LINUX_DIR)/%.ko,$(FILES)),$(strip $(FILES))),)
define Package/kmod-$(1)/install
- @for mod in $$(FILES); do \
+ @for mod in $$$$$$$$($(SCRIPT_DIR)/metadata.pl version_filter $(KERNEL_PATCHVER) $$(FILES)); do \
if [ -e $$$$$$$$mod ]; then \
mkdir -p $$(1)/$(MODULES_SUBDIR) ; \
$(CP) -L $$$$$$$$mod $$(1)/$(MODULES_SUBDIR)/ ; \