aboutsummaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-10-18 21:43:30 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-10-18 21:43:30 +0000
commitaf835ce5169cc7829928e8e224508526b9ef2870 (patch)
tree093db669aa3ce1faaf10c4575bb61d502918bedc /include/kernel.mk
parentdabd596e39c58eddc0f2361d12f415d5482307aa (diff)
downloadmaster-187ad058-af835ce5169cc7829928e8e224508526b9ef2870.tar.gz
master-187ad058-af835ce5169cc7829928e8e224508526b9ef2870.tar.bz2
master-187ad058-af835ce5169cc7829928e8e224508526b9ef2870.zip
change the way ./files* and the generic kernel files are applied. ./files now applies to *ALL* kernel versions, and is copied along with ./files-* - this gets rid of quite a bit of redundancy in the extra kernel drivers.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13010 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 5232148a6b..a9a350bb28 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -31,7 +31,7 @@ else
endif
PATCH_DIR ?= ./patches$(shell [ -d "./patches-$(KERNEL_PATCHVER)" ] && printf -- "-$(KERNEL_PATCHVER)" || true )
- FILES_DIR ?= ./files$(shell [ -d "./files-$(KERNEL_PATCHVER)" ] && printf -- "-$(KERNEL_PATCHVER)" || true )
+ FILES_DIR ?= $(foreach dir,$(wildcard ./files ./files-$(KERNEL_PATCHVER)),"$(dir)")
KERNEL_BUILD_DIR ?= $(BUILD_DIR_BASE)/linux-$(BOARD)$(if $(SUBTARGET),_$(SUBTARGET))$(if $(BUILD_SUFFIX),_$(BUILD_SUFFIX))
LINUX_DIR ?= $(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)