aboutsummaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2013-02-21 11:45:16 +0000
committerJonas Gorski <jogo@openwrt.org>2013-02-21 11:45:16 +0000
commit9c5cfcc8c9d0b98dae9ec1332c9be6123b2a68f3 (patch)
tree295a75c5bf5b624ecd6a731373a841eecb702e4e /include/kernel.mk
parentfe6dbb17814bc8c464daf4df3f2e3ee9257c96db (diff)
downloadmaster-187ad058-9c5cfcc8c9d0b98dae9ec1332c9be6123b2a68f3.tar.gz
master-187ad058-9c5cfcc8c9d0b98dae9ec1332c9be6123b2a68f3.tar.bz2
master-187ad058-9c5cfcc8c9d0b98dae9ec1332c9be6123b2a68f3.zip
include/kernel.mk: print warnings/errors to stderr
Makes warnings/errors visible when building with V=w/V=1. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35713 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 8df70ba5f6..b637de5918 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -163,11 +163,11 @@ $(call KernelPackage/$(1)/config)
if grep -q "$$$$$$$${mod##$(LINUX_DIR)/}" "$(LINUX_DIR)/modules.builtin"; then \
echo "NOTICE: module '$$$$$$$$mod' is built-in."; \
else \
- echo "ERROR: module '$$$$$$$$mod' is missing."; \
+ echo "ERROR: module '$$$$$$$$mod' is missing." >&2; \
exit 1; \
fi; \
else \
- echo "WARNING: module '$$$$$$$$mod' missing and modules.builtin not available, assuming built-in."; \
+ echo "WARNING: module '$$$$$$$$mod' missing and modules.builtin not available, assuming built-in." >&2; \
fi; \
done;
$(call ModuleAutoLoad,$(1),$$(1),$(AUTOLOAD))
@@ -178,7 +178,7 @@ $(call KernelPackage/$(1)/config)
else
compile: kmod-$(1)-unavailable
kmod-$(1)-unavailable:
- @echo "WARNING: kmod-$(1) is not available in the kernel config"
+ @echo "WARNING: kmod-$(1) is not available in the kernel config" >&2
)
endif
$$(eval $$(call BuildPackage,kmod-$(1)))