aboutsummaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2014-11-24 06:33:13 +0000
committerFlorian Fainelli <florian@openwrt.org>2014-11-24 06:33:13 +0000
commit688e48076b9d63fc68c03312418fc2516bdf8e33 (patch)
tree53de5a2d9c6ccd0c09aa57b2d3f29fd1bc05b599 /include/kernel.mk
parent379d97d851dc8a95d44a8e2acd42ad4b42fb6ab5 (diff)
downloadmaster-187ad058-688e48076b9d63fc68c03312418fc2516bdf8e33.tar.gz
master-187ad058-688e48076b9d63fc68c03312418fc2516bdf8e33.tar.bz2
master-187ad058-688e48076b9d63fc68c03312418fc2516bdf8e33.zip
aarch64: add initial support
Add initial support for the AArch64 architecture Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43353 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 28c8cf8974..01fb4dbd81 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -66,7 +66,7 @@ ifneq (,$(findstring uml,$(BOARD)))
LINUX_KARCH=um
else
ifeq (,$(LINUX_KARCH))
- LINUX_KARCH=$(strip $(subst i386,x86,$(subst armeb,arm,$(subst mipsel,mips,$(subst mips64,mips,$(subst mips64el,mips,$(subst sh2,sh,$(subst sh3,sh,$(subst sh4,sh,$(ARCH))))))))))
+ LINUX_KARCH=$(strip $(subst i386,x86,$(subst armeb,arm,$(subst mipsel,mips,$(subst mips64,mips,$(subst mips64el,mips,$(subst sh2,sh,$(subst sh3,sh,$(subst sh4,sh,$(subst aarch64,arm64,$(subst aarch64_be,arm64,$(ARCH))))))))))))
endif
endif