aboutsummaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-02-26 22:45:54 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-02-26 22:45:54 +0000
commit5f4146c474846146fa615a4da9b0535b2dc7aa61 (patch)
tree933b7f1d935b0a56e8465cf2a7f4b2fd3bf5b37c /include/kernel.mk
parent3d97332bd2ecbc75dee82a7477ae9321cec23057 (diff)
downloadmaster-187ad058-5f4146c474846146fa615a4da9b0535b2dc7aa61.tar.gz
master-187ad058-5f4146c474846146fa615a4da9b0535b2dc7aa61.tar.bz2
master-187ad058-5f4146c474846146fa615a4da9b0535b2dc7aa61.zip
add support for marking specific kernel module packages as potentially being required for mounting the rootfs (patch by cshore)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19878 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 480b9682ce..1ca2312824 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -70,6 +70,9 @@ define ModuleAutoLoad
add_module() { \
mkdir -p $(2)/etc/modules.d; \
( \
+ [ "$$$$$$$$3" = "1" ] && { \
+ echo '# May be required for rootfs' ; \
+ } ; \
for mod in $$$$$$$$2; do \
getvar mod; \
done \
@@ -154,7 +157,7 @@ $(call KernelPackage/$(1)/config)
endef
define AutoLoad
- add_module $(1) "$(2)";
+ add_module $(1) "$(2)" $(3);
endef
ifdef DUMP