aboutsummaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2013-06-22 22:09:40 +0000
committerJohn Crispin <blogic@openwrt.org>2013-06-22 22:09:40 +0000
commit21ee9d504d834133a99fecfd36f1a65f8df8c096 (patch)
tree3b2f8d6125b9eb2d40301af6408bc29ca4c3c47e /include/kernel.mk
parent81e16ac101c4fc0df7e65968fda761d72e3dbff2 (diff)
downloadmaster-187ad058-21ee9d504d834133a99fecfd36f1a65f8df8c096.tar.gz
master-187ad058-21ee9d504d834133a99fecfd36f1a65f8df8c096.tar.bz2
master-187ad058-21ee9d504d834133a99fecfd36f1a65f8df8c096.zip
package: fix insmod on install
the procd changes broke the postinst insmod. Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37015 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index b637de5918..cbf342a0d2 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -105,7 +105,7 @@ define ModuleAutoLoad
echo "#!/bin/sh" > $(2)/CONTROL/postinst; \
echo "[ -z \"\$$$$$$$$IPKG_INSTROOT\" ] || exit 0" >> $(2)/CONTROL/postinst; \
echo ". /lib/functions.sh" >> $(2)/CONTROL/postinst; \
- echo "load_modules $$$$$$$$modules" >> $(2)/CONTROL/postinst; \
+ echo "insert_modules $$$$$$$$modules" >> $(2)/CONTROL/postinst; \
chmod 0755 $(2)/CONTROL/postinst; \
fi
endef