aboutsummaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-07-05 21:31:34 +0000
committerJonas Gorski <jogo@openwrt.org>2015-07-05 21:31:34 +0000
commit160056db2dec7dd2d03b66a70fc9399b24d57778 (patch)
treecdd6921b0a1b96ea8f1ad1dde15082818fe09ce4 /include/kernel.mk
parente51825fa3cad33c88727c40d9d78188742a3a1c0 (diff)
downloadmaster-187ad058-160056db2dec7dd2d03b66a70fc9399b24d57778.tar.gz
master-187ad058-160056db2dec7dd2d03b66a70fc9399b24d57778.tar.bz2
master-187ad058-160056db2dec7dd2d03b66a70fc9399b24d57778.zip
kernel: assume modules.builtin is always present
We do not support old kernel versions not generating modules.builtin anymore, so assume it will always be present and check for modules to be built in first. This prevents old modules being packages up after changing the kernel config to include them in the kernel without cleaning the kernel tree. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46182 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk14
1 files changed, 5 insertions, 9 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 300da0d50b..7a0a170c35 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -181,18 +181,14 @@ $(call KernelPackage/$(1)/config)
ifneq ($(if $(SDK),$(filter-out $(LINUX_DIR)/%.ko,$(FILES)),$(strip $(FILES))),)
define Package/kmod-$(1)/install
@for mod in $$(call version_filter,$$(FILES)); do \
- if [ -e $$$$$$$$mod ]; then \
+ if grep -q "$$$$$$$${mod##$(LINUX_DIR)/}" "$(LINUX_DIR)/modules.builtin"; then \
+ echo "NOTICE: module '$$$$$$$$mod' is built-in."; \
+ elif [ -e $$$$$$$$mod ]; then \
mkdir -p $$(1)/$(MODULES_SUBDIR) ; \
$(CP) -L $$$$$$$$mod $$(1)/$(MODULES_SUBDIR)/ ; \
- elif [ -e "$(LINUX_DIR)/modules.builtin" ]; then \
- if grep -q "$$$$$$$${mod##$(LINUX_DIR)/}" "$(LINUX_DIR)/modules.builtin"; then \
- echo "NOTICE: module '$$$$$$$$mod' is built-in."; \
- else \
- echo "ERROR: module '$$$$$$$$mod' is missing." >&2; \
- exit 1; \
- fi; \
else \
- echo "WARNING: module '$$$$$$$$mod' missing and modules.builtin not available, assuming built-in." >&2; \
+ echo "ERROR: module '$$$$$$$$mod' is missing." >&2; \
+ exit 1; \
fi; \
done;
$(call ModuleAutoLoad,$(1),$$(1),$(AUTOLOAD))