aboutsummaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2014-12-05 11:50:42 +0000
committerJonas Gorski <jogo@openwrt.org>2014-12-05 11:50:42 +0000
commit0995439339564028367282b57f750d61ab6a69f3 (patch)
tree798b735215a65c9e8ca443c93f10877d40322c18 /include/kernel.mk
parent6c36c279686887edd6027e3f06e8960255fefb2b (diff)
downloadmaster-187ad058-0995439339564028367282b57f750d61ab6a69f3.tar.gz
master-187ad058-0995439339564028367282b57f750d61ab6a69f3.tar.bz2
master-187ad058-0995439339564028367282b57f750d61ab6a69f3.zip
sdk: don't try to build in-kernel kmods
We don't ship the kernel sources, so using the base git as a feed will fail when trying to build kernel modules with separate install steps. Instead of trying to fixup the install steps, let's just skip building kernel modules alltogether and just create empty packages. Out-of-kernel modules are still expected to exist and are packaged, as for these sources are fetched during the normal build steps. Reported-by: Jo-Philipp Wich <jow@openwrt.org> Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43525 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 01fb4dbd81..d2754abe44 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -167,7 +167,7 @@ $(call KernelPackage/$(1)/config)
$(call KernelPackage/depends)
ifneq ($(if $(filter-out %=y %=n %=m,$(KCONFIG)),$(filter m y,$(foreach c,$(filter-out %=y %=n %=m,$(KCONFIG)),$($(c)))),.),)
- ifneq ($(strip $(FILES)),)
+ ifneq ($(if $(SDK),$(filter-out $(LINUX_DIR)/%.ko,$(FILES)),$(strip $(FILES))),)
define Package/kmod-$(1)/install
@for mod in $$(FILES); do \
if [ -e $$$$$$$$mod ]; then \