aboutsummaryrefslogtreecommitdiffstats
path: root/include/kernel-defaults.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-04-26 17:53:56 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-04-26 17:53:56 +0000
commitb5f3dda1234cce36443be01e5fa3d78ca20687b3 (patch)
treeb6d40a0d7c51f13f8a2d34a3769aa5cf19e16ff5 /include/kernel-defaults.mk
parent42f83d2e571323b3536203a21e32890543b4e946 (diff)
downloadmaster-187ad058-b5f3dda1234cce36443be01e5fa3d78ca20687b3.tar.gz
master-187ad058-b5f3dda1234cce36443be01e5fa3d78ca20687b3.tar.bz2
master-187ad058-b5f3dda1234cce36443be01e5fa3d78ca20687b3.zip
build: rework verbosity level selection
V=99 and V=1 are now deprecated in favor of a new verbosity class system, though the old flags are still supported. You can set the V variable on the command line (or OPENWRT_VERBOSE in the environment) to one or more of the following characters: - s: stdout+stderr (equal to the old V=99) - c: commands (for build systems that suppress commands by default, e.g. kbuild) - w: warnings/errors only (equal to the old V=1) git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31484 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/kernel-defaults.mk')
-rw-r--r--include/kernel-defaults.mk7
1 files changed, 2 insertions, 5 deletions
diff --git a/include/kernel-defaults.mk b/include/kernel-defaults.mk
index 6864793a27..0c188502fc 100644
--- a/include/kernel-defaults.mk
+++ b/include/kernel-defaults.mk
@@ -9,7 +9,8 @@ KERNEL_MAKEOPTS := -C $(LINUX_DIR) \
CROSS_COMPILE="$(KERNEL_CROSS)" \
ARCH="$(LINUX_KARCH)" \
KBUILD_HAVE_NLS=no \
- CONFIG_SHELL="$(BASH)"
+ CONFIG_SHELL="$(BASH)" \
+ $(if $(findstring c,$(OPENWRT_VERBOSE)),V=1)
ifdef CONFIG_STRIP_KERNEL_EXPORTS
KERNEL_MAKEOPTS += \
@@ -22,10 +23,6 @@ ifneq (,$(KERNEL_CC))
KERNEL_MAKEOPTS += CC="$(KERNEL_CC)"
endif
-ifeq ($(KBUILD_VERBOSE),99)
- KERNEL_MAKEOPTS += V=1
-endif
-
export HOST_EXTRACFLAGS=-I$(STAGING_DIR_HOST)/include
# defined in quilt.mk