aboutsummaryrefslogtreecommitdiffstats
path: root/include/kernel-defaults.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-06-02 12:45:16 +0000
committerJohn Crispin <blogic@openwrt.org>2014-06-02 12:45:16 +0000
commit2c1b67136203729dea719ca40a33b44a0c73defb (patch)
tree529c60ba40c27582bc7f68bd9b9347a4b2b8483b /include/kernel-defaults.mk
parent90d0f5654ac7ee13b1706e8824014bef7eba5b09 (diff)
downloadmaster-187ad058-2c1b67136203729dea719ca40a33b44a0c73defb.tar.gz
master-187ad058-2c1b67136203729dea719ca40a33b44a0c73defb.tar.bz2
master-187ad058-2c1b67136203729dea719ca40a33b44a0c73defb.zip
config: Remove KERNEL_GIT_LOCAL_REPOSITORY option
The GIT_LOCAL_REPOSITORY option adds the --reference argument to the git clone kernel command line, if KERNEL_GIT_CLONE_URI is set. This option is intended to speed-up the repo creation by using local objets rather than downloading it. However, a local repo can be cloned much faster by setting GIT_LOCAL_REPOSITORY directly to the local tree. In that case, git clone will bypass the normal "git aware" transport mechanism and clone the repository by copying and hardlinking objects rather than downloading it, resulting in a significant speed increase. That makes the GIT_LOCAL_REPOSITORY option pretty useless so we'll just remove it and recommand the usage of KERNEL_GIT_CLONE_URI directly. Signed-off-by: Mathieu Olivari <mathieu@qca.qualcomm.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40944 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/kernel-defaults.mk')
-rw-r--r--include/kernel-defaults.mk10
1 files changed, 2 insertions, 8 deletions
diff --git a/include/kernel-defaults.mk b/include/kernel-defaults.mk
index 322aeed5fa..499ecdf3d8 100644
--- a/include/kernel-defaults.mk
+++ b/include/kernel-defaults.mk
@@ -40,15 +40,9 @@ ifeq ($(strip $(CONFIG_EXTERNAL_KERNEL_TREE)),"")
touch $(LINUX_DIR)/.quilt_used
endef
else
- ifeq ($(strip $(CONFIG_KERNEL_GIT_LOCAL_REPOSITORY)),"")
- define Kernel/Prepare/Default
+ define Kernel/Prepare/Default
git clone $(CONFIG_KERNEL_GIT_CLONE_URI) $(LINUX_DIR)
- endef
- else
- define Kernel/Prepare/Default
- git clone --reference $(CONFIG_KERNEL_GIT_LOCAL_REPOSITORY) $(CONFIG_KERNEL_GIT_CLONE_URI) $(LINUX_DIR)
- endef
- endif
+ endef
endif
else
define Kernel/Prepare/Default