aboutsummaryrefslogtreecommitdiffstats
path: root/include/kernel-defaults.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-06-02 12:45:22 +0000
committerJohn Crispin <blogic@openwrt.org>2014-06-02 12:45:22 +0000
commit059736734825e8834b9b72e2725a4d7a01644e92 (patch)
tree934d69a0e086a16b9760ebada038440af36c7659 /include/kernel-defaults.mk
parenteeb79d7591215bfe2196a072db019f50f5f9c78b (diff)
downloadmaster-187ad058-059736734825e8834b9b72e2725a4d7a01644e92.tar.gz
master-187ad058-059736734825e8834b9b72e2725a4d7a01644e92.tar.bz2
master-187ad058-059736734825e8834b9b72e2725a4d7a01644e92.zip
include: Allow git kernel branch selection
This allows the selection of a specific branch in the menuconfig when using a kernel downloaded from GIT. Signed-off-by: Mathieu Olivari <mathieu@qca.qualcomm.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40946 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/kernel-defaults.mk')
-rw-r--r--include/kernel-defaults.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/include/kernel-defaults.mk b/include/kernel-defaults.mk
index fd75a3f79f..f1f5a81313 100644
--- a/include/kernel-defaults.mk
+++ b/include/kernel-defaults.mk
@@ -38,6 +38,10 @@ ifneq ($(strip $(CONFIG_KERNEL_GIT_LOCAL_REPOSITORY)),"")
KERNEL_GIT_OPTS+=--reference $(CONFIG_KERNEL_GIT_LOCAL_REPOSITORY)
endif
+ifneq ($(strip $(CONFIG_KERNEL_GIT_BRANCH)),"")
+ KERNEL_GIT_OPTS+=--branch $(CONFIG_KERNEL_GIT_BRANCH)
+endif
+
ifeq ($(strip $(CONFIG_EXTERNAL_KERNEL_TREE)),"")
ifeq ($(strip $(CONFIG_KERNEL_GIT_CLONE_URI)),"")
define Kernel/Prepare/Default