aboutsummaryrefslogtreecommitdiffstats
path: root/include/kernel-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-06-09 15:38:45 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-06-09 15:38:45 +0000
commitf4e7bdac427e5cf7c06378fdb68e6f1780bcaff4 (patch)
treebeda70cdc408c3248d07dec3bf53f7170d5623c2 /include/kernel-build.mk
parentef36c74b06f8fdc5d4e81b1bdfc1e3ad275e560f (diff)
downloadmaster-187ad058-f4e7bdac427e5cf7c06378fdb68e6f1780bcaff4.tar.gz
master-187ad058-f4e7bdac427e5cf7c06378fdb68e6f1780bcaff4.tar.bz2
master-187ad058-f4e7bdac427e5cf7c06378fdb68e6f1780bcaff4.zip
large improvement for parallel builds. works without V=99 now and without warnings. tested with -j on an 2x dual core opteron machine
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11414 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/kernel-build.mk')
-rw-r--r--include/kernel-build.mk6
1 files changed, 1 insertions, 5 deletions
diff --git a/include/kernel-build.mk b/include/kernel-build.mk
index 9335e1a0d5..75c2bcf01a 100644
--- a/include/kernel-build.mk
+++ b/include/kernel-build.mk
@@ -8,10 +8,6 @@ include $(INCLUDE_DIR)/host.mk
include $(INCLUDE_DIR)/prereq.mk
ifneq ($(DUMP),1)
- override MAKEFLAGS=
-endif
-
-ifneq ($(DUMP),1)
all: compile
endif
@@ -101,7 +97,7 @@ define BuildKernel
@$(MAKE) compile
image-prereq:
- $(SUBMAKE) -s -C image prereq TARGET_BUILD=
+ @$(NO_TRACE_MAKE) -s -C image prereq TARGET_BUILD=
prereq: image-prereq