aboutsummaryrefslogtreecommitdiffstats
path: root/include/kernel-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-11-11 01:25:06 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-11-11 01:25:06 +0000
commit9a724ec84e675b6a625efa3eb9b1d906759c4aeb (patch)
tree07dee3c07ba60a709824992f98610da5357fd0f7 /include/kernel-build.mk
parenta228d3f366975e263d3acb7ab6596dbf0fb1f73b (diff)
downloadmaster-187ad058-9a724ec84e675b6a625efa3eb9b1d906759c4aeb.tar.gz
master-187ad058-9a724ec84e675b6a625efa3eb9b1d906759c4aeb.tar.bz2
master-187ad058-9a724ec84e675b6a625efa3eb9b1d906759c4aeb.zip
merge target kernel config files with subtarget config files and add a variable override for editing the target kernel config file with make kernel_menuconfig in case the subtarget contains overrides (thx, sn9)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18362 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/kernel-build.mk')
-rw-r--r--include/kernel-build.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/include/kernel-build.mk b/include/kernel-build.mk
index e3e446ba58..7c5d1fbe9c 100644
--- a/include/kernel-build.mk
+++ b/include/kernel-build.mk
@@ -104,7 +104,8 @@ define BuildKernel
$(LINUX_CONFCMD) > $(LINUX_DIR)/.config
touch $(LINUX_CONFIG)
$(_SINGLE)$(MAKE) -C $(LINUX_DIR) $(KERNEL_MAKEOPTS) $$@
- $(SCRIPT_DIR)/kconfig.pl '>' $(GENERIC_LINUX_CONFIG) $(LINUX_DIR)/.config > $(if $(LINUX_SUBCONFIG),$(LINUX_SUBCONFIG),$(LINUX_CONFIG))
+ $(SCRIPT_DIR)/kconfig.pl '>' $(if $(LINUX_SUBCONFIG),'+' $(GENERIC_LINUX_CONFIG) $(LINUX_CONFIG),$(GENERIC_LINUX_CONFIG)) \
+ $(LINUX_DIR)/.config > $(if $(LINUX_SUBCONFIG),$(LINUX_SUBCONFIG),$(LINUX_CONFIG))
$(Kernel/Configure)
install: $(LINUX_DIR)/.image