aboutsummaryrefslogtreecommitdiffstats
path: root/include/kernel-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-09-06 16:27:37 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-09-06 16:27:37 +0000
commit92558d67a463bfbb351d30e28648de03b635f024 (patch)
treea5d41b991a151e72663527a96fbc6c494565d65c /include/kernel-build.mk
parente1dbce411cd2a3a067f387cee011cd889486a07d (diff)
downloadmaster-187ad058-92558d67a463bfbb351d30e28648de03b635f024.tar.gz
master-187ad058-92558d67a463bfbb351d30e28648de03b635f024.tar.bz2
master-187ad058-92558d67a463bfbb351d30e28648de03b635f024.zip
strip the kernel version suffix from target directories, except for brcm-2.4 (the -2.4 will be included in the board name here). CONFIG_LINUX_<ver>_<board> becomes CONFIG_TARGET_<board>, same for profiles.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8653 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/kernel-build.mk')
-rw-r--r--include/kernel-build.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/include/kernel-build.mk b/include/kernel-build.mk
index 0d3b40e16f..69e602aded 100644
--- a/include/kernel-build.mk
+++ b/include/kernel-build.mk
@@ -110,7 +110,8 @@ define BuildKernel
ifeq ($(DUMP),1)
dumpinfo:
- @echo 'Target: $(BOARD)-$(KERNEL)'
+ @echo 'Target: $(BOARD)'
+ @echo 'Target-Kernel: $(KERNEL)'
@echo 'Target-Name: $(BOARDNAME) [$(KERNEL)]'
@echo 'Target-Path: $(subst $(TOPDIR)/,,$(PWD))'
@echo 'Target-Arch: $(ARCH)'