aboutsummaryrefslogtreecommitdiffstats
path: root/include/kernel-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-03-23 14:48:47 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-03-23 14:48:47 +0000
commit1b3722a5f80090e74b9ec1b159fcd03ae82f5010 (patch)
treedf1cf207dd818164def00c8bc0bc2bc7e5605413 /include/kernel-build.mk
parent1759c808172f0b9a972362aeb1112925346151d2 (diff)
downloadmaster-187ad058-1b3722a5f80090e74b9ec1b159fcd03ae82f5010.tar.gz
master-187ad058-1b3722a5f80090e74b9ec1b159fcd03ae82f5010.tar.bz2
master-187ad058-1b3722a5f80090e74b9ec1b159fcd03ae82f5010.zip
some cleanups in the metadata.pl script; allow target profiles to add overrides for menuconfig
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6648 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/kernel-build.mk')
-rw-r--r--include/kernel-build.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/include/kernel-build.mk b/include/kernel-build.mk
index 3193e9d185..b2837d1df3 100644
--- a/include/kernel-build.mk
+++ b/include/kernel-build.mk
@@ -220,6 +220,7 @@ confname=$(subst .,_,$(subst -,_,$(1)))
define Profile
$(eval $(call Profile/Default))
$(eval $(call Profile/$(1)))
+ $(eval $(call shexport,Profile/$(1)/Config))
$(eval $(call shexport,Profile/$(1)/Description))
DUMPINFO += \
echo "Target-Profile: $(1)"; \
@@ -228,6 +229,9 @@ define Profile
if [ -f ./config/profile-$(1) ]; then \
echo "Target-Profile-Kconfig: yes"; \
fi; \
+ echo "Target-Profile-Config: "; \
+ getvar "$(call shvar,Profile/$(1)/Config)"; \
+ echo "@@"; \
echo "Target-Profile-Description:"; \
getvar "$(call shvar,Profile/$(1)/Description)"; \
echo "@@"; \