aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-08-14 15:10:47 +0000
committerJonas Gorski <jogo@openwrt.org>2015-08-14 15:10:47 +0000
commitf3fe638bd50385197214354448f41075b899bde7 (patch)
tree7dc593fa78005692e3fa69b0e0593c1bce8e810c /include/image.mk
parent7b5ff07e20ca5dd0036202f7722dd173e8e8af9f (diff)
downloadmaster-187ad058-f3fe638bd50385197214354448f41075b899bde7.tar.gz
master-187ad058-f3fe638bd50385197214354448f41075b899bde7.tar.bz2
master-187ad058-f3fe638bd50385197214354448f41075b899bde7.zip
brcm63xx: move gzip build command to include/image.mk
Allow other targets to make use of it. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46601 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/include/image.mk b/include/image.mk
index 56c60d6087..73fc805bb5 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -323,6 +323,11 @@ define Build/lzma
@mv $@.new $@
endef
+define Build/gzip
+ gzip -9n -c $@ $(1) > $@.new
+ @mv $@.new $@
+endef
+
define Build/kernel-bin
rm -f $@
cp $^ $@