aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-12-19 11:15:41 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-12-19 11:15:41 +0000
commitebc034d20f0a07a25d86b1e48cf3c6259f1c6f9e (patch)
tree0b0d595c86e7af91779ca7fa63b586df356a17a4 /include/image.mk
parent970d926bff7f8b606e93e6dc257a2c36ccdf3a37 (diff)
downloadmaster-187ad058-ebc034d20f0a07a25d86b1e48cf3c6259f1c6f9e.tar.gz
master-187ad058-ebc034d20f0a07a25d86b1e48cf3c6259f1c6f9e.tar.bz2
master-187ad058-ebc034d20f0a07a25d86b1e48cf3c6259f1c6f9e.zip
image.mk: use cross toolchain cpp for processing dts file instead of relying on the host compiler
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47937 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index 6b2fb1afd8..1522dd72c8 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -142,7 +142,7 @@ endef
# $(3) extra CPP flags
# $(4) extra DTC flags
define Image/BuildDTB
- $(CPP) -nostdinc -x assembler-with-cpp \
+ $(TARGET_CROSS)cpp -nostdinc -x assembler-with-cpp \
-I$(DTS_DIR) \
-I$(DTS_DIR)/include \
-undef -D__DTS__ $(3) \