aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-05-29 13:41:31 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-05-29 13:41:31 +0000
commite2ad5c96d5de229fb5d8a0b560b8b753577b767b (patch)
treed5c2686c82f288178c4a8f4f94f7d061e58e58b7 /include/image.mk
parent9272d8d2f77a9be2399a358711f92c27c5230a10 (diff)
downloadmaster-187ad058-e2ad5c96d5de229fb5d8a0b560b8b753577b767b.tar.gz
master-187ad058-e2ad5c96d5de229fb5d8a0b560b8b753577b767b.tar.bz2
master-187ad058-e2ad5c96d5de229fb5d8a0b560b8b753577b767b.zip
build: do not call initramfs build from within the image builder
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45837 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index 051f0f7e53..36c6c63320 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -471,7 +471,7 @@ define BuildImage
kernel_prepare: mkfs_prepare
$(call Image/BuildKernel)
- $(if $(CONFIG_TARGET_ROOTFS_INITRAMFS),$(call Image/BuildKernel/Initramfs))
+ $(if $(CONFIG_TARGET_ROOTFS_INITRAMFS),$(if $(IB),,$(call Image/BuildKernel/Initramfs)))
$(call Image/InstallKernel)
$(foreach device,$(TARGET_DEVICES),$(call Device,$(device)))