aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-01-11 16:44:26 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-01-11 16:44:26 +0000
commitc87db17012cc2cec83da79e847fe7283dc6117ad (patch)
treee256fb745d387297d0e4845b723948a6caab7fe4 /include/image.mk
parent2e12554148f3d82f2ced45efea51a59dc2a452b1 (diff)
downloadmaster-187ad058-c87db17012cc2cec83da79e847fe7283dc6117ad.tar.gz
master-187ad058-c87db17012cc2cec83da79e847fe7283dc6117ad.tar.bz2
master-187ad058-c87db17012cc2cec83da79e847fe7283dc6117ad.zip
image.mk: use XZ bcj architecture filter if available
xz supports using an architecture specific BCJ filter, use that one to save us a couple kB while producing squashfs filesystems (mimics the Linux kernel). Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35097 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index 503115ddb0..7c45b39462 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -50,7 +50,10 @@ ifeq ($(CONFIG_SQUASHFS_LZMA),y)
SQUASHFSCOMP := lzma $(LZMA_XZ_OPTIONS)
endif
ifeq ($(CONFIG_SQUASHFS_XZ),y)
- SQUASHFSCOMP := xz $(LZMA_XZ_OPTIONS)
+ ifneq ($(filter arm x86 powerpc sparc,$(LINUX_KARCH)),)
+ BCJ_FILTER:=-Xbcj $(LINUX_KARCH)
+ endif
+ SQUASHFSCOMP := xz $(LZMA_XZ_OPTIONS) $(BCJ_FILTER)
endif
JFFS2_BLOCKSIZE ?= 64k 128k