aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-08-03 01:21:41 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-08-03 01:21:41 +0000
commitc29e1265711b2ebb87dd2910c8605ba6dc1f5a90 (patch)
tree78b00c052af6f13a91994d9b97337edc0d6b5224 /include/image.mk
parent78cbbeec55a3321f116446338f177ff54ca6c53c (diff)
downloadmaster-187ad058-c29e1265711b2ebb87dd2910c8605ba6dc1f5a90.tar.gz
master-187ad058-c29e1265711b2ebb87dd2910c8605ba6dc1f5a90.tar.bz2
master-187ad058-c29e1265711b2ebb87dd2910c8605ba6dc1f5a90.zip
fix image installation
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8324 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk7
1 files changed, 5 insertions, 2 deletions
diff --git a/include/image.mk b/include/image.mk
index d00f779fe9..b094428770 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -8,6 +8,9 @@
include $(INCLUDE_DIR)/prereq.mk
include $(INCLUDE_DIR)/kernel.mk
include $(INCLUDE_DIR)/host.mk
+
+override MAKEFLAGS=
+override MAKE:=$(SUBMAKE)
KDIR:=$(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)
ifneq ($(CONFIG_BIG_ENDIAN),y)
@@ -94,14 +97,14 @@ define BuildImage
download:
prepare:
ifneq ($(IB),1)
- compile: compile-targets
+ compile: compile-targets FORCE
$(call Build/Compile)
else
compile:
endif
ifneq ($(IB),1)
- install: compile install-targets
+ install: compile install-targets FORCE
$(call Image/Prepare)
$(call Image/mkfs/prepare)
$(call Image/BuildKernel)