aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-07-14 09:57:45 +0000
committerJohn Crispin <blogic@openwrt.org>2015-07-14 09:57:45 +0000
commitb5bb9272ee773d30c1fde2da17c087618264ab6f (patch)
tree682cca857e1946d5a258823cfa55f3c40d9daa64 /include/image.mk
parentb5f4a9f364263f9f1fdc5093b00b223154aaf5fc (diff)
downloadmaster-187ad058-b5bb9272ee773d30c1fde2da17c087618264ab6f.tar.gz
master-187ad058-b5bb9272ee773d30c1fde2da17c087618264ab6f.tar.bz2
master-187ad058-b5bb9272ee773d30c1fde2da17c087618264ab6f.zip
build: Prevent more gzip timestamps
To improve reproducibility, prevent the inclusion of timestamps in the gzip header. Signed-off-by: Reiner Herrmann <reiner@reiner-h.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46361 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index 814e7dc5d1..6767e76dc1 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -224,7 +224,7 @@ ifneq ($(CONFIG_TARGET_ROOTFS_UBIFS),)
endif
define Image/mkfs/cpiogz
- ( cd $(TARGET_DIR); find . | cpio -o -H newc | gzip -9 >$(BIN_DIR)/$(IMG_PREFIX)-rootfs.cpio.gz )
+ ( cd $(TARGET_DIR); find . | cpio -o -H newc | gzip -9n >$(BIN_DIR)/$(IMG_PREFIX)-rootfs.cpio.gz )
endef
define Image/mkfs/targz